Difference between revisions of "20181121-Analyzer-Mtg"

From PREX Wiki
Jump to: navigation, search
(Agenda)
 
(One intermediate revision by the same user not shown)
Line 14: Line 14:
 
== Agenda ==
 
== Agenda ==
 
# online plots
 
# online plots
#*  
+
#* CG: will be ready to hand tasks to students to create config files next meeting
 +
#* CG: still having trouble connecting to memory resident file but for now we'll move ahead with reading from disk files
 
# regression analysis
 
# regression analysis
#*  
+
#* PK: getting memory resident root files to work was top priority
 
# et_bridge and deadtime: Cameron  
 
# et_bridge and deadtime: Cameron  
#*  
+
#* BM: no updates
 
# naming conventions:
 
# naming conventions:
#*
+
#* CG: will change names for cav should have a 4 and no underscore
 +
#* PK: we are still planning to have a separate cavity class, which should be very simple because it doesn’t do much.
 +
#* PK: should we have a cav4D_x name that differentiates between raw and calibrated? BM: the cavity really gives the position (in some arbitrary units).
 +
#* PK: for the stripline we have a RelativeX which is a reported value from the stripline and X would be what we calculate by taking into consideration geometry offsets. KP: we should just remove RelativeX but have X as default to use 0 geometry offsets unless set.
 +
#* PK: do we want to change effectiveCharge into ws (wire sum)? KP: we should use wire sums because they auto-gain and would not be a good indicator of charge.
 +
#* PK: we should not have any naming extensions on the detector channels (or words that are similar to detectors).
 
# DAQ Question: do we want banks, headers, or both ?  (no problem to have both)
 
# DAQ Question: do we want banks, headers, or both ?  (no problem to have both)
 +
#* BM: the advantage of banks is that you can’t get lost, but that would break pan decoding. We can keep pan decoding if we put a header word in the bank which japan ignores and pan would still work.
 +
#* PK: the way I implemented the marker work in japan makes things possibly break if you have both marker words and banks. Can we have pan treat the bank header as the marker word? BM: sounds like a possibility, will investigate.
 +
#* BM: the philosophy will be that we keep all the similar data (VQWKs for example) in the same bank and put everything else into a misc bank (like helicity, scandata, scalers)
 +
# VQWK adcs:
 +
#* CC: changed 2 VQWK in the CH crate and will talk to Chris C to see if he can repair it. BM: we are getting the test crate ready and will check the remaining 5 VQWKs.
  
 
== Present ==
 
== Present ==
 +
Paul K, Ciprian G, Kent P, Tao Y, Bob M, Ye T, Cameron C,
  
 
===Excused===
 
===Excused===

Latest revision as of 12:43, 21 November 2018

Back to Main Page >> Analyzer_Meeting

previous meeting << >> following meeting

Logistic information

 BlueJeans calling instructions:
 Toll-Free Number (U.S.&  Canada):  888-240-2560
 International toll number:         408-740-7256
 Bluejeans CODE:                  684 884 269
 Bluejeans link: https://bluejeans.com/684884269

github repository: JAPAN

Agenda

  1. online plots
    • CG: will be ready to hand tasks to students to create config files next meeting
    • CG: still having trouble connecting to memory resident file but for now we'll move ahead with reading from disk files
  2. regression analysis
    • PK: getting memory resident root files to work was top priority
  3. et_bridge and deadtime: Cameron
    • BM: no updates
  4. naming conventions:
    • CG: will change names for cav should have a 4 and no underscore
    • PK: we are still planning to have a separate cavity class, which should be very simple because it doesn’t do much.
    • PK: should we have a cav4D_x name that differentiates between raw and calibrated? BM: the cavity really gives the position (in some arbitrary units).
    • PK: for the stripline we have a RelativeX which is a reported value from the stripline and X would be what we calculate by taking into consideration geometry offsets. KP: we should just remove RelativeX but have X as default to use 0 geometry offsets unless set.
    • PK: do we want to change effectiveCharge into ws (wire sum)? KP: we should use wire sums because they auto-gain and would not be a good indicator of charge.
    • PK: we should not have any naming extensions on the detector channels (or words that are similar to detectors).
  5. DAQ Question: do we want banks, headers, or both ? (no problem to have both)
    • BM: the advantage of banks is that you can’t get lost, but that would break pan decoding. We can keep pan decoding if we put a header word in the bank which japan ignores and pan would still work.
    • PK: the way I implemented the marker work in japan makes things possibly break if you have both marker words and banks. Can we have pan treat the bank header as the marker word? BM: sounds like a possibility, will investigate.
    • BM: the philosophy will be that we keep all the similar data (VQWKs for example) in the same bank and put everything else into a misc bank (like helicity, scandata, scalers)
  6. VQWK adcs:
    • CC: changed 2 VQWK in the CH crate and will talk to Chris C to see if he can repair it. BM: we are getting the test crate ready and will check the remaining 5 VQWKs.

Present

Paul K, Ciprian G, Kent P, Tao Y, Bob M, Ye T, Cameron C,

Excused